]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/networking/ssh.nix
wireguard: clean up a bit
[sourcephile-nix.git] / hosts / losurdo / networking / ssh.nix
1 { pkgs, lib, config, hosts, ... }:
2 let
3 inherit (config.security) gnupg;
4 inherit (config.users) users;
5 in
6 {
7 systemd.services.ssh-mermet-reverse = {
8 after = [ "network-online.target" ];
9 wantedBy = [ "multi-user.target" ];
10 serviceConfig = {
11 Type = "simple";
12 # Require services.openssh.gatewayPorts = "clientspecified";
13 # on the target.
14 ExecStart = ''${pkgs.openssh}/bin/ssh -v -g -N -T \
15 -o ServerAliveInterval=10 \
16 -o ExitOnForwardFailure=yes \
17 -R *:10022:localhost:22 \
18 ${hosts.mermet.extraArgs.ipv4}
19 '';
20 Restart = "always";
21 RestartSec = "5s";
22 };
23 };
24 boot.initrd.network.ssh = {
25 enable = true;
26 port = 2222;
27 authorizedKeys = users.root.openssh.authorizedKeys.keys;
28 hostKeys = [ "/root/initrd/ssh.key" ];
29 extraConfig = ''
30 '';
31 };
32 services.openssh = {
33 forwardX11 = true;
34 };
35 programs.ssh = {
36 extraConfig = ''
37 Compression = yes
38 '';
39 };
40 services.upnpc.redirections =
41 [
42 { description = "SSH";
43 externalPort = 22; protocol = "TCP"; duration = 30 * 60;
44 service.wantedBy = ["sshd.service"];
45 service.partOf = ["sshd.service"];
46 }
47 { description = "Mosh"; externalPort = 60000; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
48 { description = "Mosh"; externalPort = 60001; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
49 { description = "Mosh"; externalPort = 60002; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
50 { description = "Mosh"; externalPort = 60003; protocol = "UDP"; duration = 30 * 60; service.wantedBy = ["sshd.service"]; }
51 ] ++ [
52 { description = "SSH (boot)";
53 externalPort = 2222; protocol = "TCP"; duration = 0;
54 service.wantedBy = ["sshd.service"];
55 }
56 ];
57 }