1 { stdenv, fetchurl, perl }:
3 stdenv.mkDerivation rec {
4 baseName = "shorewall-core";
6 name = "${baseName}-${version}";
9 url = "http://www.shorewall.net/pub/shorewall/5.2/shorewall-5.2.0/${baseName}-${version}.tar.bz2";
10 sha256 = "1156n42dz8g44d7f336dn7q97xcq6bl18b2gv2diydv02lc8fqbd";
20 CONFDIR=\$PREFIX/etc \
21 SBINDIR=\$PREFIX/sbin \
22 SYSCONFDIR=\$PREFIX/etc/default \
31 # Remove hardcoded PATH
32 sed -i $out/share/shorewall/lib.cli \
37 homepage = http://www.shorewall.net/;
38 description = "A gateway/firewall configuration tool for GNU/Linux";
40 Shorewall is a high-level tool for configuring Netfilter. You describe your
41 firewall/gateway requirements using entries in a set of configuration
42 files. Shorewall reads those configuration files and with the help of the
43 iptables, iptables-restore, ip and tc utilities, Shorewall configures
44 Netfilter and the Linux networking subsystem to match your requirements.
45 Shorewall can be used on a dedicated firewall system, a multi-function
46 gateway/router/server or on a standalone GNU/Linux system. Shorewall does
47 not use Netfilter's ipchains compatibility mode and can thus take
48 advantage of Netfilter's connection state tracking capabilities.
50 license = stdenv.lib.licenses.gpl2Plus;
51 platforms = stdenv.lib.platforms.linux;