]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
nix: update inputs
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 system = "x86_64-linux";
5 modules = [
6 {
7 config._module.args = {
8 CPUs = 2;
9 };
10 config.install.substituteOnDestination = false;
11 }
12 ../nixos/defaults.nix
13 ../nixos/profiles/systems/debug.nix
14 #carotte/fileSystems.nix
15
16 carotte/hardware.nix
17 carotte/hostapd.nix
18 carotte/networking.nix
19 carotte/security.nix
20 carotte/system.nix
21 carotte/users.nix
22 (inputs.secrets + "/hosts/${hostName}/users.nix")
23 #carotte/xserver.nix
24 ];
25 }