1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
8 "vm.vfs_cache_pressure" = 50;
19 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
23 { devices = [ "${disk_id}" ];
24 path = "/boot${bootnum}";
31 canTouchEfiVariables = true;
32 efiSysMountPoint = "/boot/efi";
33 efiInstallAsRemovable = false;
39 availableKernelModules = [
46 # Made the AES modules available at initrd,
47 # to speedup the deciphering of the root.
55 boot.kernelModules = [ ];
56 boot.extraModulePackages = [ ];
60 "console=ttyS0,115200n8"
61 "zfs.zfs_arc_max=262144000" # 250Mo
65 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
69 fileSystems."/boot/efi" =
70 { device = "/dev/disk/by-uuid/62E6-E65F";
75 [ { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
78 cipher = "aes-xts-plain64";
79 source = "/dev/urandom";
84 nix.maxJobs = lib.mkDefault 4;
85 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
88 systemPackages = with pkgs; [