1 { pkgs, lib, config, ... }:
3 inherit (builtins.extraBuiltins) pass git;
4 inherit (pkgs.lib) unlinesAttrs types;
5 inherit (config) networking;
6 inherit (config.services) knot;
7 inherit (config) users;
8 # Use the Git commit time of the ${domain}.nix file to set the serial number.
9 # WARNING: the ${domain}.nix must be committed into Git for this to work.
10 # WARNING: this does not take other .nix into account, though they may contribute to the zone's data.
11 serial = domain: toString (git ./. [ "log" "-1" "--format=%ct" "--" (domain + ".nix") ]);
12 mermetIPv4 = "80.67.180.129";
13 losurdoIPv4 = "80.67.180.251";
14 domain = "sourcephile.fr";
17 systemd.services."acme-${domain}".after = [
20 security.acme.certs."${domain}" = {
21 email = "root@${domain}";
25 group = users.groups.acme.name;
26 allowKeysForGroup = true;
28 dnsProvider = "rfc2136";
29 credentialsFile = pkgs.writeText "credentials" ''
30 RFC2136_NAMESERVER=127.0.0.1:5353
31 LEGO_EXPERIMENTAL_CNAME_SUPPORT=1
34 services.knot.zones."${domain}" = {
37 - id: acl_acme_challenge_sourcephile_fr
41 update-owner-match: equal
42 update-owner-name: [_acme-challenge.${domain}]
48 serial-policy: increment
50 notify: secondary_gandi
52 acl: acl_acme_challenge_sourcephile_fr
56 # TODO: increase the TTL once things have settled down
61 ; SOA (Start Of Authority)
63 ${serial domain} ; Serial number
66 1000h ; Expire (1000h)
76 mermet A ${mermetIPv4}
77 losurdo A ${losurdoIPv4}
78 autoconfig A ${mermetIPv4}
87 submission A ${mermetIPv4}
89 lemoutona5pattes A ${mermetIPv4}
90 covid19 A ${mermetIPv4}
92 ; SPF (Sender Policy Framework)
93 @ 3600 IN SPF "v=spf1 mx ip4:${mermetIPv4} -all"
94 @ 3600 IN TXT "v=spf1 mx ip4:${mermetIPv4} -all"
100 _git._tcp.git 18000 IN SRV 0 0 9418 git
102 ; CAA (Certificate Authority Authorization)
103 ; DOC: https://blog.qualys.com/ssllabs/2017/03/13/caa-mandated-by-cabrowser-forum
104 @ CAA 128 issue "letsencrypt.org"
107 /* Useless since the zone is public
108 services.unbound.extraConfig = ''
110 name: "sourcephile.fr"
111 stub-addr: 127.0.0.1@5353