]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
mermet: fix shorewall
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
6 let
7 deployment = builtins.getAttr
8 ( lib.maybeEnv "NIXOPS_DEPLOYMENT" "production")
9 deployments;
10 deployments = {
11 production = [
12 mermet/machine/apu2e4.nix
13 mermet/hosting/ptt.nix
14 ];
15 staging = [
16 mermet/machine/virtualbox.nix
17 mermet/hosting/localhost.nix
18 ];
19 };
20 in
21 {
22 nixpkgs.overlays = import ../overlays.nix;
23 imports =
24 [ ../nixos/defaults.nix
25 mermet/system.nix
26 ] ++ deployment;
27 }