]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/public-inbox.nix
public-inbox: test sur mermet
[sourcephile-nix.git] / servers / mermet / public-inbox.nix
1 { pkgs, lib, config, ... }:
2 let domain = "sourcephile.fr"; in
3 {
4 #networking.firewall.allowedTCPPorts = [ 119 563 ];
5 services.public-inbox = {
6 enable = true;
7 path = with pkgs; [ /*spamassassin*/ ];
8 #mda.args = [ "--no-precheck" ];
9 mda.spamCheck = null;
10 watch.spamCheck = null;
11 #nntp.extraGroups = [ "tls" ];
12 wwwListing = "match=domain";
13
14 config.publicinbox.sourceinfo = ''
15 '';
16
17 #config.publicinbox.css =
18 # [ "href=https://${domain}/lists/public-inbox.css" ];
19
20 http.mounts = [ "https://${domain}/lists" ];
21 #nntp.cert = "/var/lib/acme/${domain}/fullchain.pem";
22 #nntp.key = "/var/lib/acme/${domain}/key.pem";
23 #nntpServer = [ "nntps://${domain}" "nntp://${domain}" ];
24
25 inboxes = {
26 equipage = {
27 address = [
28 "public-inbox+equipage@${domain}"
29 "equipage@${domain}"
30 ];
31 description = "Équipage";
32 url = "https://${domain}/lists/equipage";
33 #newsgroup = "inbox.comp.sourcephile.announce";
34 #config.coderepo = [ "sourcephile" ];
35 };
36 };
37
38 /*
39 config.coderepo.sourcephile-nix = {
40 dir = "/var/lib/git/repositories/sourcephile.git";
41 cgitUrl = "https://${domain}/git/sourcephile";
42 };
43 */
44 };
45 }