1 { pkgs, inputs, hostName, ... }:
4 (inputs.julm-nix + "/nixos/profiles/zfs.nix")
8 device = "${hostName}/root";
9 fsType = "zfs"; # TODO: options = [ "zfsutil" ];
12 boot.zfs.requestEncryptionCredentials = [ hostName ];
14 fileSystems."/nix" = {
15 device = "${hostName}/nix";
19 fileSystems."/var" = {
20 device = "${hostName}/var";
24 fileSystems."/var/cache" = {
25 device = "${hostName}/var/cache";
29 fileSystems."/var/log" = {
30 device = "${hostName}/var/log";
34 fileSystems."/var/tmp" = {
35 device = "${hostName}/var/tmp";
39 fileSystems."/mnt/key" = {
40 device = "/dev/disk/by-label/key";
42 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
45 # Allow members of the "adbusers" group to mount Android devices via MTP
46 services.udev.packages = [ pkgs.android-udev-rules ];
47 environment.systemPackages = [