1 { pkgs, lib, config, ... }:
2 # NOTE: list explicitely the modules loaded by defaults.nix,
3 # its clearer, safer and more flexible if not quicker.
6 modules/services/networking/domains.nix
7 modules/services/databases/openldap.nix
12 # NOTE: this modules.nix file is put in the imports of the configuration.nix,
13 # but using the lib.findFiles defined in the nixpkgs.overlays leads to an infinite recursion,
14 # hence it is redefined here:
15 let findFiles = pattern:
18 let dir = readDir curr; in
19 let files = lib.filterAttrs (name: type:
21 match pattern name != null) dir; in
22 let dirs = lib.filterAttrs (name: type: type == "directory") dir; in
23 map (name: "${curr}/${name}") (attrNames files) ++
24 lib.concatMap (name: go "${curr}/${name}") (attrNames dirs)
29 imports = findFiles ".*\\.nix" ./modules;