]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/production.nix
nix: revamp the config paths
[sourcephile-nix.git] / servers / mermet / production.nix
1 { pkgs, lib, config, options
2 # NixOps extra module inputs
3 , nodes, name, uuid, resources
4 , ... }:
5 let inherit (config) networking; in
6 {
7 imports = [
8 ./keys.nix
9 production/apu2e4.nix
10 production/lesptts.nix
11 production/zfs.nix
12 production/shorewall.nix
13 ];
14 deployment = {
15 targetEnv = "none";
16 targetHost = (builtins.elemAt networking.interfaces.enp1s0.ipv4.addresses 0).address;
17 };
18 }