]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/production/apu2e4.nix
nix: revamp the config paths
[sourcephile-nix.git] / servers / mermet / production / apu2e4.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../base/apu2e4.nix
5 ];
6
7 boot.loader.grub.devices = [
8 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
9 ];
10
11 fileSystems."/boot" =
12 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
13 fsType = "ext2";
14 };
15
16 fileSystems."/boot/efi" =
17 { device = "/dev/disk/by-uuid/62E6-E65F";
18 fsType = "vfat";
19 };
20
21 swapDevices =
22 [ { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
23 randomEncryption = {
24 enable = true;
25 cipher = "aes-xts-plain64";
26 source = "/dev/urandom";
27 };
28 }
29 ];
30 }