1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
16 configurationLimit = 1;
18 # In case canTouchEfiVariables doesn't work
19 #efiInstallAsRemovable = true;
21 # Completed in the importing configuration
25 { devices = [ "${disk_id}" ];
26 path = "/boot${bootnum}";
33 canTouchEfiVariables = true;
34 efiSysMountPoint = "/boot/efi";
40 availableKernelModules = [
48 # Made the AES modules available at initrd,
49 # to speedup the deciphering of the root.
62 "console=ttyS0,115200n8"
63 # Use arc_summary to print stats
64 "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
67 environment.systemPackages = [