1 { pkgs, lib, config, ... }:
3 hardware.cpu.intel.updateMicrocode = true;
5 # Too CPU hungry for the DL10J, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
16 configurationLimit = 3;
18 # Because canTouchEfiVariables doesn't work on this system
19 efiInstallAsRemovable = true;
21 # Completed in the importing configuration
25 { devices = [ "${disk_id}" ];
26 path = "/boot${bootnum}";
32 canTouchEfiVariables = false;
33 efiSysMountPoint = "/boot/efi";
38 availableKernelModules = [
40 "ehci_pci" # useless ?
42 "mei_me" # Communication controller
43 "nvme" # NVME M.2 disk
44 #"rtl8188ee" # Wireless
45 "rtsx_usb_sdmmc" # SD card
46 #"snd_hda_intel" # Audio
51 # Made the AES modules available at initrd,
52 # to speedup the deciphering of the root.
59 "nvme" # NVME M.2 disk
60 "rtsx_usb_sdmmc" # SD card
63 boot.kernelModules = [ ];
64 boot.extraModulePackages = [ ];
67 "console=ttyS0,115200n8"
68 "console=ttyS1,115200n8"
70 # Use arc_summary to print stats
71 "zfs.zfs_arc_max=${toString (1000 * 1024 * 1024)}" # bytes
74 environment.systemPackages = with pkgs; [