]> Git — Sourcephile - sourcephile-nix.git/blob - machines/mermet/security.nix
nftables: retake at ICMPv6 and other stuffs
[sourcephile-nix.git] / machines / mermet / security.nix
1 { inputs, pkgs, lib, config, machineName, ... }:
2 let
3 inherit (config.security) gnupg;
4 rootKey = "root/key";
5 initrdKey = "initrd/ssh.key";
6 keygrip = "89F52A879E0019A966503AFFDE72EEA84CDFA3A7";
7 in
8 {
9 security.gnupg.store = inputs.pass + "/machines/${machineName}";
10 environment.memoryAllocator.provider = "libc";
11 services.openssh.extraConfig = ''
12 StreamLocalBindUnlink yes
13 '';
14 }