]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet.nix
mermet: fix networking
[sourcephile-nix.git] / servers / mermet.nix
1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 {pkgs, lib, config, options, nodes, resources, ...}:
6 let
7 inherit (builtins.extraBuiltins) pass;
8 in
9 {
10 # This value determines the NixOS release with which your system is to be
11 # compatible, in order to avoid breaking some software such as database
12 # servers. You should change this only after NixOS release notes say you should.
13 system.stateVersion = "19.09"; # Did you read the comment?
14
15 nixpkgs.overlays = import ../overlays.nix;
16
17 imports =
18 [ ../nixos/defaults.nix
19 mermet/apu2e4.nix
20 mermet/zfs.nix
21 mermet/lesptts.nix
22 mermet/shorewall.nix
23 ];
24
25 networking = {
26 hostName = "mermet";
27 domain = "sourcephile.fr";
28 };
29
30 users = {
31 mutableUsers = false;
32 users = {
33 root = rec {
34 initialPassword = password;
35 password = pass "servers/mermet/login/root";
36 openssh.authorizedKeys.keys = [
37 (pass "members/julm/ssh.pub")
38 ];
39 };
40 };
41 groups = {
42 };
43 };
44
45 environment = {
46 systemPackages = with pkgs; [
47 cryptsetup
48 fio
49 git
50 gptfdisk
51 lm_sensors
52 smartctl-tbw
53 ];
54 };
55 }