1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
7 ./defaults/predictable-interface-names.nix
11 #binaryCaches = lib.mkForce [];
14 # Use gc.automatic to keep disk space under control.
18 options = "--delete-older-than 30d";
21 ("nixpkgs=" + toString pkgs.path)
29 packageOverrides = pkgs: {
30 postfix = pkgs.postfix.override {
36 #overlays = import ../overlays.nix;
39 documentation.nixos = {
40 enable = false; # NOTE: useless on a server, and CPU intensive.
43 # Clean /tmp automatically on boot.
44 boot.cleanTmpDir = true;
47 timeZone = "Europe/Paris";
51 defaultLocale = "fr_FR.UTF-8";
55 font = "Lat2-Terminus16";
62 passwordAuthentication = false;
74 #checkConfigurationOptions = false;
75 systemPackages = with pkgs; [
95 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
100 interactiveShellInit = ''
101 bind '"\e[A":history-search-backward'
102 bind '"\e[B":history-search-forward'
104 # Ignore duplicate commands, ignore commands starting with a space
105 export HISTCONTROL=erasedups:ignorespace
106 export HISTSIZE=42000
108 # Append to the history instead of overwriting (good for multiple connections)
115 ls = "ls --color=tty";
116 mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
119 s-u="systemctl --user";
121 nixos-clean="sudo nix-collect-garbage -d";
122 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
123 nixos-rollback="sudo nixos-rebuild switch --rollback";
124 nixos-update="sudo nix-channel --update";
125 nixos-upgrade="sudo nixos-rebuild switch";
126 nixos-upstream="sudo nix-channel --list";
131 pinentryFlavor = "curses";