1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options, ... }:
7 inherit (builtins) readFile;
8 inherit (builtins.extraBuiltins) pass pass-chomp;
11 # This value determines the NixOS release with which your system is to be
12 # compatible, in order to avoid breaking some software such as database servers.
13 # You should change this only after NixOS release notes say you should.
14 system.stateVersion = "19.09"; # Did you read the comment?
17 autoOptimiseStore = true;
18 trustedUsers = [ "julm" ];
21 nixpkgs.overlays = import ../overlays.nix;
24 [ ../nixos/defaults.nix
37 domainBase = "sourcephile";
38 domain = "${domainBase}.fr";
45 initialPassword = password;
46 password = pass-chomp "servers/mermet/login/root";
47 openssh.authorizedKeys.keys = [
48 (readFile ../../sec/ssh/julm.pub)
49 (readFile ../../sec/ssh/julm-mob.pub)
62 systemPackages = with pkgs; [