1 { pkgs, lib, config, machineName, ... }:
2 let inherit (config.security) gnupg; in
6 interval = "*-*-* *:15:00";
7 sshKey = gnupg.secrets."/root/.ssh/id_ed25519".path;
13 "${machineName}/home/julm/work" = {
15 target = "root@mermet.sourcephile.fr:rpool/backup/${machineName}/home/julm/work";
17 "${machineName}/var/postgresql" = {
19 target = "root@mermet.sourcephile.fr:rpool/backup/${machineName}/var/postgresql";
21 "root@mermet.sourcephile.fr:rpool/var/mail" = {
23 target = "${machineName}/backup/mermet/var/mail";
25 "root@mermet.sourcephile.fr:rpool/var/public-inbox" = {
27 target = "${machineName}/backup/mermet/var/public-inbox";
29 "root@mermet.sourcephile.fr:rpool/var/www" = {
31 target = "${machineName}/backup/mermet/var/www";
33 "root@mermet.sourcephile.fr:rpool/var/git" = {
35 target = "${machineName}/backup/mermet/var/git";
37 "root@mermet.sourcephile.fr:rpool/var/redis" = {
39 target = "${machineName}/backup/mermet/var/redis";
41 "root@mermet.sourcephile.fr:rpool/home/julm/mail" = {
43 target = "${machineName}/backup/mermet/home/julm/mail";
45 "root@mermet.sourcephile.fr:rpool/home/julm/log" = {
47 target = "${machineName}/backup/mermet/home/julm/log";