12 settings.X11Forwarding = true;
14 systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
15 "host.key:${ssh/host.key.cred}"
21 security.initrd.secrets."${hostName}/ssh/initrd.key" = "hosts/${hostName}/ssh/initrd.key.gpg";
22 boot.initrd.network.ssh = {
25 authorizedKeys = config.users.users.root.openssh.authorizedKeys.keys;
26 hostKeys = [ "${config.security.initrd.stage1Dir}/${hostName}/ssh/initrd.key" ];
30 systemd.services.ssh-mermet-reverse = {
31 #after = [ "network-online.target" ];
32 wantedBy = [ "multi-user.target" ];
35 # Require services.openssh.gatewayPorts = "clientspecified";
38 ${pkgs.openssh}/bin/ssh -v -g -N -T \
39 -o ServerAliveInterval=10 \
40 -o ExitOnForwardFailure=yes \
41 -R *:10022:localhost:22 \
42 ${hosts.mermet._module.args.ipv4}
48 services.upnpc.enable = true;
49 services.upnpc.redirections =
56 service.wantedBy = [ "sshd.service" ];
57 service.partOf = [ "sshd.service" ];
64 service.wantedBy = [ "sshd.service" ];
71 service.wantedBy = [ "sshd.service" ];
78 service.wantedBy = [ "sshd.service" ];
85 service.wantedBy = [ "sshd.service" ];
90 description = "SSH (boot)";
94 service.wantedBy = [ "sshd.service" ];