1 { pkgs, lib, config, ... }:
3 hardware.cpu.intel.updateMicrocode = true;
5 # Too CPU hungry for the DL10J, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
14 "vm.vfs_cache_pressure" = 50;
23 configurationLimit = 3;
25 # Vecause canTouchEfiVariables doesn't work on this system
26 efiInstallAsRemovable = true;
28 # Completed in the importing configuration
32 { devices = [ "${disk_id}" ];
33 path = "/boot${bootnum}";
39 canTouchEfiVariables = false;
40 efiSysMountPoint = "/boot/efi";
45 availableKernelModules = [
47 "ehci_pci" # useless ?
49 "mei_me" # Communication controller
50 "nvme" # NVME M.2 disk
51 #"rtl8188ee" # Wireless
52 "rtsx_usb_sdmmc" # SD card
53 #"snd_hda_intel" # Audio
58 # Made the AES modules available at initrd,
59 # to speedup the deciphering of the root.
66 "nvme" # NVME M.2 disk
67 "rtsx_usb_sdmmc" # SD card
70 boot.kernelModules = [ ];
71 boot.extraModulePackages = [ ];
74 "console=ttyS0,115200n8"
75 "console=ttyS1,115200n8"
77 # Use arc_summary to print stats
78 "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
81 environment.systemPackages = with pkgs; [