]> Git — Sourcephile - sourcephile-nix.git/blob - servers/losurdo/production/fileSystems.nix
losurdo: boot on SD and root on NVMe
[sourcephile-nix.git] / servers / losurdo / production / fileSystems.nix
1 { pkgs, lib, config, ... }:
2 {
3 imports = [
4 ../../../base/zfs.nix
5 ];
6
7 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
8 # You should try to make this id unique among your machines.
9 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
10 networking.hostId = "69c40b03";
11
12 /*
13 # Enable the (OpenSolaris-compatible) ZFS auto-snapshotting service.
14 services.zfs.autoSnapshot = {
15 enable = true;
16 frequent = ;
17 hourly = ;
18 daily = ;
19 weekly = ;
20 monthly = ;
21 };
22 */
23
24 boot.loader.grub.devices = [
25 #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
26 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
27 "/dev/disk/by-id/mmc-SB32G_0xdb5e2237"
28 ];
29
30 fileSystems."/boot" =
31 { device = "/dev/disk/by-partlabel/losurdo_sd_boot";
32 fsType = "ext2";
33 };
34
35 fileSystems."/boot/efi" =
36 { device = "/dev/disk/by-partlabel/losurdo_sd_efi";
37 fsType = "vfat";
38 };
39
40 swapDevices =
41 [ { device = "/dev/disk/by-partlabel/losurdo_nvme_swap";
42 randomEncryption = {
43 enable = true;
44 cipher = "aes-xts-plain64";
45 source = "/dev/urandom";
46 };
47 }
48 ];
49
50 fileSystems."/" =
51 { device = "losurdo_nvme/root";
52 fsType = "zfs";
53 };
54
55 fileSystems."/home" =
56 { device = "losurdo_nvme/home";
57 fsType = "zfs";
58 };
59
60 fileSystems."/nix" =
61 { device = "losurdo_nvme/nix";
62 fsType = "zfs";
63 };
64
65 fileSystems."/var" =
66 { device = "losurdo_nvme/var";
67 fsType = "zfs";
68 };
69
70 fileSystems."/var/cache" =
71 { device = "losurdo_nvme/var/cache";
72 fsType = "zfs";
73 };
74
75 fileSystems."/var/log" =
76 { device = "losurdo_nvme/var/log";
77 fsType = "zfs";
78 };
79
80 fileSystems."/var/tmp" =
81 { device = "losurdo_nvme/var/tmp";
82 fsType = "zfs";
83 };
84 }