]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/system.nix
nix: commit changes during work on services.transmission
[sourcephile-nix.git] / machines / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 in
5 {
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
10
11 # Avoid the use of systemd-run --user --scope tmux
12 # and let mosh work smoothly.
13 services.logind.killUserProcesses = false;
14
15 nix.gc.dates = "daily";
16 nix.gc.options = "--delete-older-than 7d";
17
18 services.unbound.enable = true;
19
20 environment.systemPackages = with pkgs; [
21 cryptsetup
22 direnv
23 file
24 fio
25 gdb
26 git
27 gptfdisk
28 #hey
29 home-manager
30 lm_sensors
31 rsync
32 smartctl-tbw
33 socat
34 sanoid
35 #iptables-nftables-compat
36 gnupg
37 miniupnpc
38 audit
39 python
40 ];
41 }