]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/profiles/hardware/apu2e4.nix
nix: commit changes during work on services.transmission
[sourcephile-nix.git] / nixos / profiles / hardware / apu2e4.nix
1 { pkgs, lib, config, ... }:
2 {
3 hardware.cpu.amd.updateMicrocode = true;
4 nix = {
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
7 maxJobs = 4;
8 };
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
10
11 boot.loader = {
12 grub = {
13 enable = true;
14 version = 2;
15 copyKernels = true;
16 configurationLimit = 1;
17 # efiSupport = true;
18 # In case canTouchEfiVariables doesn't work
19 #efiInstallAsRemovable = true;
20 devices = [
21 # Completed in the importing configuration
22 ];
23 /*
24 mirroredBoots = [
25 { devices = [ "${disk_id}" ];
26 path = "/boot${bootnum}";
27 }
28 ];
29 */
30 };
31 /*
32 efi = {
33 canTouchEfiVariables = true;
34 efiSysMountPoint = "/boot/efi";
35 };
36 */
37 };
38
39 boot.initrd = {
40 availableKernelModules = [
41 "ahci"
42 "ehci_pci"
43 "sd_mod"
44 "sg"
45 "uas"
46 # Ethernet driver
47 "igb"
48 # Made the AES modules available at initrd,
49 # to speedup the deciphering of the root.
50 "aes_x86_64"
51 "aesni_intel"
52 "cryptd"
53 ];
54 kernelModules = [
55 "igb"
56 ];
57 };
58
59 boot.kernelParams = [
60 "gfxpayload=text"
61 #"console=tty0"
62 "console=ttyS0,115200n8"
63 # Use arc_summary to print stats
64 "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
65 ];
66
67 environment.systemPackages = [
68 pkgs.pciutils
69 pkgs.flashrom
70 ];
71 }