]> Git — Sourcephile - sourcephile-nix.git/blob - shell.nix
nix: fix nixpkgs-channel and gpg-agent
[sourcephile-nix.git] / shell.nix
1 let
2 nixpkgs = import .config/nixpkgs-channel/nixos-19.09-small.nix;
3 pkgs = import nixpkgs {
4 config = {}; # Make the config pure, ignoring user's config.
5 overlays = import ./overlays.nix;
6 };
7 lib = pkgs.lib;
8 nixos = pkgs.nixos {};
9 # Configuration of shell/modules/
10 configuration = {config, ...}: {
11 imports = [
12 ];
13 nix = {
14 nixConf = ''
15 auto-optimise-store = true
16 '';
17 };
18 nix-plugins = {
19 enable = true;
20 };
21 gnupg = {
22 enable = true;
23 gnupgHome = toString ../sec/gnupg;
24 keys = import shell/openpgp.nix;
25 };
26 openssl = {
27 enable = true;
28 opensslHome = toString ../sec/openssl;
29 certificates = import shell/x509.nix;
30 };
31 openssh = {
32 # WARNING: nixops uses its own ssh, not this one.
33 enable = true;
34 sshConf = ''
35 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com,aes256-ctr
36 Compression no
37 #CompressionLevel 4
38 ControlMaster auto
39 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
40 HashKnownHosts no
41 #SSAPIAuthentication no
42 SendEnv LANG LC_*
43 StrictHostKeyChecking yes
44 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
45 '';
46 };
47 };
48
49 # Using modules enables to separate specific configurations
50 # from reusable code in shell/modules.nix and shell/modules/
51 # which may find its way in another git repository one day.
52 modules =
53 (import shell/modules.nix {
54 inherit pkgs lib;
55 modules = [ configuration ];
56 }).config;
57 in
58 pkgs.stdenv.mkDerivation {
59 name = "sourcephile-nix";
60 src = null;
61 #preferLocalBuild = true;
62 #allowSubstitutes = false;
63 buildInputs = modules.nix-shell.buildInputs ++ [
64 nixpkgs
65 nixos.nixos-generate-config
66 nixos.nixos-install
67 nixos.nixos-enter
68 #pkgs.binutils
69 pkgs.coreutils
70 pkgs.cryptsetup
71 pkgs.curl
72 #pkgs.direnv
73 pkgs.dnsutils
74 #pkgs.dropbear
75 pkgs.e2fsprogs
76 pkgs.git
77 pkgs.glibcLocales
78 pkgs.gnumake
79 pkgs.gnupg
80 pkgs.htop
81 #pkgs.inetutils
82 pkgs.ipcalc
83 #pkgs.iputils
84 pkgs.less
85 pkgs.libfaketime
86 #pkgs.mailutils
87 pkgs.man
88 pkgs.mdadm
89 pkgs.gptfdisk
90 pkgs.ncdu
91 pkgs.ncurses
92 pkgs.nixops
93 #pkgs.openssl
94 pkgs.pass
95 pkgs.procps
96 pkgs.rsync
97 #pkgs.rxvt_unicode.terminfo
98 #pkgs.sqlite
99 pkgs.sqlite
100 pkgs.sudo
101 pkgs.tig
102 pkgs.time
103 #pkgs.tmux
104 pkgs.tree
105 pkgs.utillinux
106 pkgs.vim
107 #pkgs.virtualbox
108 pkgs.which
109 pkgs.xdg_utils
110 pkgs.zfs
111 pkgs.fio
112 pkgs.strace
113 pkgs.utillinux
114 #pkgs.zfstools
115 ];
116 #enableParallelBuilding = true;
117 shellHook = ''
118 echo >&2 "nix: running shellHook"
119
120 # Cleanup "../sec/tmp/"
121 # This is done when exiting the nix-shell
122 # (or when… entering the directory with direnv
123 # which spawns a nix-shell just to get the env).
124 trap "cd '$PWD' && find ../sec/tmp -type f -exec shred -fu {} +" EXIT
125
126 ${modules.nix-shell.shellHook}
127
128 # nix
129 export NIX_PATH="nixpkgs=${nixpkgs}"
130 NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
131 #NIX_PATH+=""
132
133 # executables
134 PATH_NIX="$(dirname "$(PATH="${builtins.getEnv "PATH"}"; which nix)")"
135 PATH_NIXOS=/run/wrappers/bin
136 PATH_FHS="$PWD"/.config/nix/fhs-bin
137 PATH_FHS_VBOX="$PWD"/.config/fhs-vbox-bin
138 export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
139
140 # NOTE: sudo needs to be own by root with the setuid bit,
141 # but this won't be the case for the sudo provided by Nix outside NixOS,
142 # hence the addition of $PATH_FHS in shellHook
143 # to provide the host system's sudo.
144 # WARNING: beware that sudo may reset the environment,
145 # and especially PATH, to some system's default.
146
147 # locales
148 export LANG=fr_FR.UTF-8
149 export LC_CTYPE=fr_FR.UTF-8
150
151 # password-store
152 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
153
154 # git
155 gitdir="$PWD"/.git
156 test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
157 ln -fnsr \
158 "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
159 "$gitdir"/hooks/prepare-commit-msg
160
161 # nixops
162 #export NIXOPS_DEPLOYMENT="staging"
163 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
164 NIXOPS_OPTS+=" --show-trace"
165 export NIXOPS_OPTS
166
167 # disnix
168 #export DISNIXOS_USE_NIXOPS=1
169 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
170 #export DISNIX_PROFILE=default
171 #export DISNIX_TARGET_PROPERTY=hostname
172 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia
173 '';
174 }