1 { pkgs, lib, config, machineName, ... }:
4 ../../nixos/profiles/systems/zfs.nix
8 { device = "${machineName}/root";
11 boot.zfs.requestEncryptionCredentials = [ machineName ];
14 { device = "${machineName}/home";
18 fileSystems."/home/julm" =
19 { device = "${machineName}/home/julm";
23 fileSystems."/home/julm/work" =
24 { device = "${machineName}/home/julm/work";
29 { device = "${machineName}/nix";
34 { device = "${machineName}/var";
38 fileSystems."/var/cache" =
39 { device = "${machineName}/var/cache";
43 fileSystems."/var/log" =
44 { device = "${machineName}/var/log";
48 fileSystems."/var/lib/nginx" =
49 { device = "${machineName}/var/www";
53 fileSystems."/var/lib/postgresql" =
54 { device = "${machineName}/var/postgresql";
55 fsType = "zfs"; # with sync=always,
56 # though loading OpenConcerto's initial SQL
57 # takes 1m40s instead of 40s :\
60 fileSystems."/var/lib/transmission" =
61 { device = "${machineName}/var/torrents";
65 fileSystems."/var/tmp" =
66 { device = "${machineName}/var/tmp";
70 fileSystems."/mnt/key" =
71 { device = "/dev/disk/by-label/key";
73 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];