]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/system.nix
nix: move some pkgs to julm-nix
[sourcephile-nix.git] / hosts / mermet / system.nix
1 { pkgs, lib, config, inputs, hostName, ... }:
2 let inherit (config) networking; in
3 {
4 # This value determines the NixOS release with which your system is to be
5 # compatible, in order to avoid breaking some software such as database servers.
6 # You should change this only after NixOS release notes say you should.
7 system.stateVersion = "19.09"; # Did you read the comment?
8
9 services.unbound.enable = true;
10
11 nix.gc.dates = "daily";
12 nix.gc.options = "--delete-older-than 2d";
13
14 environment.systemPackages = with pkgs; [
15 cryptsetup
16 fio
17 git
18 gptfdisk
19 #hey
20 lm_sensors
21 rsync
22 socat
23 ];
24 }