1 { pkgs, lib, config, ... }:
5 ./defaults/predictable-interface-names.nix
9 autoOptimiseStore = true;
12 # Use gc.automatic to keep disk space under control.
16 options = "--delete-older-than 30d";
24 packageOverrides = pkgs: {
25 postfix = pkgs.postfix.override {
31 #overlays = import ../overlays.nix;
34 documentation.nixos = {
35 enable = false; # NOTE: useless on this machine, and CPU intensive.
39 timeZone = "Europe/Paris";
43 consoleFont = "Lat2-Terminus16";
45 defaultLocale = "fr_FR.UTF-8";
62 systemPackages = with pkgs; [
77 etc."inputrc".text = lib.readFile defaults/readline/inputrc;
82 interactiveShellInit = ''
83 bind '"\e[A":history-search-backward'
84 bind '"\e[B":history-search-forward'
86 # Ignore duplicate commands, ignore commands starting with a space
87 export HISTCONTROL=erasedups:ignorespace
90 # Append to the history instead of overwriting (good for multiple connections)
97 ls = "ls --color=tty";
100 s-u="systemctl --user";
102 nixos-clean="sudo nix-collect-garbage -d";
103 nixos-history="sudo nix-env --list-generations --profile /nix/var/nix/profiles/system";
104 nixos-rollback="sudo nixos-rebuild switch --rollback";
105 nixos-update="sudo nix-channel --update";
106 nixos-upgrade="sudo nixos-rebuild switch";
107 nixos-upstream="sudo nix-channel --list";