1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
14 "vm.vfs_cache_pressure" = 50;
25 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
29 { devices = [ "${disk_id}" ];
30 path = "/boot${bootnum}";
37 canTouchEfiVariables = true;
38 efiSysMountPoint = "/boot/efi";
39 efiInstallAsRemovable = false;
45 availableKernelModules = [
52 # Made the AES modules available at initrd,
53 # to speedup the deciphering of the root.
61 boot.kernelModules = [ ];
62 boot.extraModulePackages = [ ];
66 "console=ttyS0,115200n8"
67 "zfs.zfs_arc_max=262144000" # 250Mo
71 { device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
75 fileSystems."/boot/efi" =
76 { device = "/dev/disk/by-uuid/62E6-E65F";
81 [ { device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
84 cipher = "aes-xts-plain64";
85 source = "/dev/urandom";
91 systemPackages = with pkgs; [