]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
nix: format all .nix files
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 nixpkgs.hostPlatform = {
5 system = "armv7l-linux";
6 config = "armv7l-unknown-linux-gnueabihf";
7 };
8 imports = [
9 {
10 install.substituteOnDestination = false;
11 }
12 ../nixos/defaults.nix
13 ../nixos/profiles/systems/debug.nix
14 #carotte/fileSystems.nix
15
16 carotte/hardware.nix
17 carotte/hostapd.nix
18 carotte/networking.nix
19 carotte/security.nix
20 carotte/system.nix
21 carotte/users.nix
22 (inputs.secrets + "/hosts/${hostName}/users.nix")
23 #carotte/xserver.nix
24 ];
25 }