4 (inputs.julm-nix + "/nixos/profiles/zfs.nix")
9 { device = "bpool/boot";
14 device = "rpool/root";
15 fsType = "zfs"; # TODO: options = [ "zfsutil" ];
18 # This will automatically load the zfs password prompt on login
19 # and kill the other prompt so boot can continue
20 # The pkill zfs kills the zfs load-key from the console
21 # allowing the boot to continue.
22 boot.initrd.network.postCommands = ''
23 echo >>/root/.profile "zfs load-key rpool && pkill zfs"
25 boot.zfs.requestEncryptionCredentials = lib.mkForce [ "rpool" ];
26 #boot.zfs.requestEncryptionCredentials = [ hostName ];
30 device = "rpool/home";
34 fileSystems."/home/julm" =
36 device = "rpool/home/julm";
40 fileSystems."/home/julm/log" =
42 device = "rpool/home/julm/log";
46 fileSystems."/home/julm/mail" =
48 device = "rpool/home/julm/mail";
64 fileSystems."/var/cache" =
66 device = "rpool/var/cache";
70 fileSystems."/var/log" =
72 device = "rpool/var/log";
76 fileSystems."/var/tmp" =
78 device = "rpool/var/tmp";
82 fileSystems."/var/www" =
84 device = "rpool/var/www";