]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/hardware.nix
nix: format all .nix files
[sourcephile-nix.git] / hosts / mermet / hardware.nix
1 { inputs, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/apu2e4.nix
5 (inputs.julm-nix + "/nixos/profiles/zramSwap.nix")
6 ];
7
8 # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
9 # You should try to make this id unique among your hosts.
10 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
11 networking.hostId = "69c40b03";
12
13 boot.loader.grub.devices = [
14 "/dev/disk/by-id/ata-Samsung_SSD_840_EVO_250GB_S1DBNSAF340110R"
15 ];
16
17 fileSystems."/boot" =
18 {
19 device = "/dev/disk/by-uuid/dc3c5387-17d2-43b3-bfa2-bf73afacca07";
20 fsType = "ext2";
21 };
22
23 fileSystems."/boot/efi" =
24 {
25 device = "/dev/disk/by-uuid/62E6-E65F";
26 fsType = "vfat";
27 };
28
29 swapDevices = [
30 {
31 device = "/dev/disk/by-partuuid/6b1eaa35-776b-4e60-b21e-7bcee535dd8b";
32 randomEncryption = {
33 enable = true;
34 cipher = "aes-xts-plain64";
35 source = "/dev/urandom";
36 };
37 }
38 ];
39 }