]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/mermet/system.nix
nix: format all .nix files
[sourcephile-nix.git] / hosts / mermet / system.nix
1 { pkgs, config, ... }:
2 {
3 # This value determines the NixOS release with which your system is to be
4 # compatible, in order to avoid breaking some software such as database servers.
5 # You should change this only after NixOS release notes say you should.
6 system.stateVersion = "19.09"; # Did you read the comment?
7
8 services.unbound.enable = true;
9
10 nix.gc.dates = "daily";
11 nix.gc.options = "--delete-older-than 2d";
12
13 environment.systemPackages = with pkgs; [
14 cryptsetup
15 fio
16 git
17 gptfdisk
18 #hey
19 lm_sensors
20 rsync
21 socat
22 ];
23 }