]> Git — Sourcephile - sourcephile-nix.git/blob - shell/modules/shells/nix-shell.nix
nix: format all .nix files
[sourcephile-nix.git] / shell / modules / shells / nix-shell.nix
1 { lib, ... }:
2 let inherit (lib) types;
3 in
4 {
5 options = {
6 nix-shell.buildInputs = lib.mkOption {
7 type = types.listOf types.package;
8 default = [ ];
9 description = ''
10 To be prepended to the shell.nix's buildInputs.
11 '';
12 };
13 nix-shell.shellHook = lib.mkOption {
14 type = types.lines;
15 default = "";
16 description = ''
17 To be prepended to the shell.nix's shellHook.
18 '';
19 };
20 };
21 }