2 nixpkgs = import .lib/nix/nixpkgs.nix;
3 pkgs = import nixpkgs {
4 config = {}; # Make the config pure, ignoring user's config.
5 overlays = import ./overlays.nix;
10 # Configuration of shell/modules/
11 configuration = {config, ...}: {
16 auto-optimise-store = true
24 gnupgHome = toString ../sec/gnupg;
25 keys = import shell/openpgp.nix;
29 opensslHome = toString ../sec/openssl;
30 certificates = import shell/x509.nix;
33 # WARNING: nixops uses its own ssh, not this one.
36 Ciphers aes256-gcm@openssh.com,aes128-gcm@openssh.com
40 ControlPath ${builtins.toString ../sec/ssh}/ssh-%h-%p-%r.socket
42 #SSAPIAuthentication no
44 StrictHostKeyChecking yes
45 UserKnownHostsFile ${builtins.toString ../sec/ssh/known_hosts}
50 # Using modules enables to separate specific configurations
51 # from reusable code in shell/modules.nix and shell/modules/
52 # which may find its way in another git repository one day.
54 (import shell/modules.nix {
56 modules = [ configuration ];
59 pkgs.stdenv.mkDerivation {
60 name = "sourcephile-nix";
62 #preferLocalBuild = true;
63 #allowSubstitutes = false;
64 buildInputs = modules.nix-shell.buildInputs ++ [
66 nixos.nixos-generate-config
98 #pkgs.rxvt_unicode.terminfo
117 #enableParallelBuilding = true;
119 echo >&2 "nix: running shellHook"
121 # Cleanup "../sec/tmp/"
122 # This is done when exiting the nix-shell
123 # (or when… entering the directory with direnv
124 # which spawns a nix-shell just to get the env).
125 trap "cd '$PWD' && find ../sec/tmp -type f -exec shred -fu {} +" EXIT
127 ${modules.nix-shell.shellHook}
130 export NIX_PATH="nixpkgs=${nixpkgs}"
131 NIX_PATH+=":nixpkgs-overlays="$PWD"/overlays"
135 PATH_NIX="$(dirname "$(PATH="${builtins.getEnv "PATH"}"; which nix)")"
136 PATH_NIXOS=/run/wrappers/bin
137 PATH_FHS="$PWD"/.lib/nix/fhs-bin
138 PATH_FHS_VBOX="$PWD"/.lib/fhs-vbox-bin
139 export PATH="$PATH_NIXOS:$PATH_FHS_VBOX:$PATH_FHS:$PATH:$PATH_NIX"
141 # NOTE: sudo needs to be own by root with the setuid bit,
142 # but this won't be the case for the sudo provided by Nix outside NixOS,
143 # hence the addition of $PATH_FHS in shellHook
144 # to provide the host system's sudo.
145 # WARNING: beware that sudo may reset the environment,
146 # and especially PATH, to some system's default.
149 export LANG=fr_FR.UTF-8
150 export LC_CTYPE=fr_FR.UTF-8
153 export PASSWORD_STORE_DIR="$PWD"/../sec/pass
157 test ! -f "$gitdir" || while IFS=" :" read -r hdr gitdir; do [ "$hdr" != gitdir ] || break; done <"$gitdir"
159 "$PWD"/.lib/git/hooks/prepare-commit-msg--longuest-common-prefix \
160 "$gitdir"/hooks/prepare-commit-msg
163 #export NIXOPS_DEPLOYMENT="staging"
164 export NIXOPS_STATE="$PWD"/../sec/nixops/state.nixops
165 NIXOPS_OPTS+=" --show-trace"
169 #export DISNIXOS_USE_NIXOPS=1
170 #export DISNIX_CLIENT_INTERFACE=disnix-nixops-client
171 #export DISNIX_PROFILE=default
172 #export DISNIX_TARGET_PROPERTY=hostname
173 #export DYSNOMIA_STATEDIR="$PWD"/../sec/dysnomia