]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
carotte: avoid compiling zfs-kernel, and enable gpg-agent
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, ... }:
3 {
4 system = "x86_64-linux";
5 extraArgs = {
6 CPUs = 2;
7 };
8 modules = [
9 ../nixos/defaults.nix
10 #carotte/fileSystems.nix
11 carotte/hardware.nix
12 carotte/networking.nix
13 carotte/security.nix
14 carotte/system.nix
15 carotte/users.nix
16 (inputs.secrets + "/hosts/${hostName}/users.nix")
17 (inputs.secrets + "/hosts/${hostName}/security.nix")
18 carotte/xserver.nix
19 ];
20 }