]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/hardware.nix
wireguard: setup in initrd
[sourcephile-nix.git] / machines / losurdo / hardware.nix
1 { pkgs, lib, config, machineName, ... }:
2 {
3 imports = [
4 ../../nixos/profiles/hardware/dl10j.nix
5 ../../nixos/profiles/systems/zramSwap.nix
6 ];
7
8 # The 32-bit host id of the machine, formatted as 8 hexadecimal characters.
9 # You should try to make this id unique among your machines.
10 # Manually generated with : head -c4 /dev/urandom | od -A none -t x4 | cut -d ' ' -f 2
11 networking.hostId = "e18f71a6";
12
13 boot.loader.grub.devices = [
14 #"/dev/disk/by-id/nvme-Samsung_SSD_970_EVO_Plus_250GB_S4EUNJ0N211426T"
15 #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
16 "/dev/disk/by-id/mmc-SB32G_0xdb5e2237"
17 ];
18
19 fileSystems."/boot" =
20 { device = "/dev/disk/by-partlabel/${machineName}_sd_boot";
21 fsType = "ext2";
22 };
23
24 fileSystems."/boot/efi" =
25 { device = "/dev/disk/by-partlabel/${machineName}_sd_efi";
26 fsType = "vfat";
27 };
28
29 swapDevices = [
30 { device = "/dev/disk/by-partlabel/${machineName}_nvme_swap";
31 randomEncryption = {
32 enable = true;
33 cipher = "aes-xts-plain64";
34 source = "/dev/urandom";
35 };
36 }
37 ];
38 }