]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/losurdo/fileSystems.nix
losurdo: systemd: enable in stage-1
[sourcephile-nix.git] / hosts / losurdo / fileSystems.nix
1 { pkgs, inputs, hostName, ... }:
2 {
3 imports = [
4 (inputs.julm-nix + "/nixos/profiles/zfs.nix")
5 ];
6
7 fileSystems."/" = {
8 device = "${hostName}/root";
9 fsType = "zfs"; # TODO: options = [ "zfsutil" ];
10 };
11
12 boot.zfs.requestEncryptionCredentials = [ hostName ];
13
14 fileSystems."/nix" = {
15 device = "${hostName}/nix";
16 fsType = "zfs";
17 };
18
19 fileSystems."/var" = {
20 device = "${hostName}/var";
21 fsType = "zfs";
22 };
23
24 fileSystems."/var/cache" = {
25 device = "${hostName}/var/cache";
26 fsType = "zfs";
27 };
28
29 fileSystems."/var/log" = {
30 device = "${hostName}/var/log";
31 fsType = "zfs";
32 };
33
34 fileSystems."/var/tmp" = {
35 device = "${hostName}/var/tmp";
36 fsType = "zfs";
37 };
38
39 fileSystems."/mnt/key" = {
40 device = "/dev/disk/by-label/key";
41 fsType = "vfat";
42 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
43 };
44
45 # Allow members of the "adbusers" group to mount Android devices via MTP
46 services.udev.packages = [ pkgs.android-udev-rules ];
47 environment.systemPackages = [
48 pkgs.go-mtpfs
49 pkgs.ntfs3g
50 ];
51
52 }