1 { pkgs, lib, config, ... }:
3 hardware.cpu.amd.updateMicrocode = true;
5 # Too CPU hungry for the APU2, for too little Mio saved
6 autoOptimiseStore = false;
9 powerManagement.cpuFreqGovernor = lib.mkDefault "ondemand";
14 "vm.vfs_cache_pressure" = 50;
25 # Completed in the importing configuration
29 { devices = [ "${disk_id}" ];
30 path = "/boot${bootnum}";
37 canTouchEfiVariables = true;
38 efiSysMountPoint = "/boot/efi";
39 efiInstallAsRemovable = false;
45 availableKernelModules = [
52 # Made the AES modules available at initrd,
53 # to speedup the deciphering of the root.
61 boot.kernelModules = [ ];
62 boot.extraModulePackages = [ ];
66 "console=ttyS0,115200n8"
67 # Use arc_summary to print stats
68 "zfs.zfs_arc_max=${toString (500 * 1024 * 1024)}" # bytes
72 systemPackages = with pkgs; [