1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options, ... }@attrs:
7 inherit (builtins) getEnv hasAttr readFile;
8 inherit (builtins.extraBuiltins) pass pass-chomp;
9 inherit (config.users) users;
12 # This value determines the NixOS release with which your system is to be
13 # compatible, in order to avoid breaking some software such as database servers.
14 # You should change this only after NixOS release notes say you should.
15 system.stateVersion = "19.09"; # Did you read the comment?
18 trustedUsers = [ users."julm".name ];
22 (./. + ("/" + getEnv "LOSURDO_DEPLOYMENT" + ".nix"))
24 ../../base/unbound.nix
26 ] ++ lib.optionals (! hasAttr "nodes" attrs) [
33 domainBase = "sourcephile";
34 domain = "${domainBase}.fr";
38 environment.etc."sudo.conf".text = ''
39 Debug sudo /var/log/sudo_debug.log all@debug
40 Debug sudoers.so /var/log/sudo_debug.log all@debug
48 openssh.authorizedKeys.keys = [
49 (readFile ../../../sec/ssh/julm.pub)
50 (readFile ../../../sec/ssh/julm-mob.pub)
55 hashedPassword = pass-chomp "servers/losurdo/login/julm/hashedPassword";
57 openssh.authorizedKeys.keys = [
58 (readFile ../../../sec/ssh/julm.pub)
59 (readFile ../../../sec/ssh/julm-mob.pub)
60 #(readFile ../../../sec/ssh/julm-losurdo.pub)
66 members = [ users."julm".name ];
69 members = [ users."julm".name ];
75 systemd.coredump.enable = true;
78 enableDebugInfo = true;
79 systemPackages = with pkgs; [