1 { pkgs, lib, config, system, ... }:
3 inherit (builtins) toString toFile readFile;
4 inherit (builtins.extraBuiltins) pass;
6 inherit (pkgs.lib) loadFile unlines unlinesAttrs unlinesValues unwords;
7 inherit (config) networking;
8 inherit (config.services) dovecot2 postfix openldap;
10 # NOTE: nixpkgs' dovecot2.stateDir is currently not exported
11 stateDir = "/var/lib/dovecot";
13 sieve_pipe_bin_dir = pkgs.buildEnv {
14 name = "sieve_pipe_bin_dir";
15 pathsToLink = [ "/bin" ];
21 learn-spam = pkgs.writeShellScriptBin "learn-spam.sh" ''
22 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_spam
24 learn-ham = pkgs.writeShellScriptBin "learn-ham.sh" ''
25 exec ${pkgs.rspamd}/bin/rspamc -h /run/rspamd/learner.sock learn_ham
28 dovecot-virtual = pkgs.buildEnv {
29 name = "dovecot-virtual";
30 pathsToLink = [ "/" ];
33 dovecot-virtual-recents
36 dovecot-virtual-all = pkgs.writeTextFile {
37 name = "dovecot-virtual-all";
38 destination = "/All/dovecot-virtual";
44 dovecot-virtual-recents = pkgs.writeTextFile {
45 name = "dovecot-virtual-recents";
46 destination = "/Recents/dovecot-virtual";
52 dovecot-virtual-pop3 = pkgs.writeTextFile {
53 name = "dovecot-virtual-pop3";
54 destination = "/pop3/INBOX/dovecot-virtual";
64 dovecot/autoconfig.nix
66 systemd.services.dovecot2 = {
70 "${networking.domain}.key.pem-key.service"
73 #users.users."${dovecot2.mailUser}".isSystemUser = true; # Fix nixpkgs
77 pkgs.dovecot_pigeonhole
78 pkgs.dovecot_fts_xapian
84 protocols = [ "sieve" ];
85 # If needed, may be overrided by userdb_mail= in passdb, or mail= in userdb
86 # Here INDEX and CONTROL are separated,
87 # it's not useful since there is not quota at the filesystem level
88 # it's just to let this possibility later on.
89 mailLocation = "sdbox:${stateDir}/mail/%d/%n/mail.d:UTF-8:CONTROL=${stateDir}/control/%d/%n:INDEX=${stateDir}/index/%d/%n";
90 createMailUser = false;
95 global = dovecot/sieve/global;
102 log_timestamp = "%Y-%m-%d %H:%M:%S "
105 ssl_dh = <${../../../sec/openssl/dh.pem}
106 ssl_cipher_list = HIGH:!LOW:!SSLv2:!EXP:!aNULL
107 ssl_cert = <${loadFile (../../../sec + "/openssl/${networking.domain}/cert.self-signed.pem")}
108 ssl_key = </run/keys/${networking.domain}.key.pem
109 #ssl_ca = <''${caPath}
110 #ssl_verify_client_cert = yes
113 # If needed, may be overrided by userdb_mail
114 mail_home = ${stateDir}/mail/%d/%n
115 # Read multiple mails in parallel, improves performance
116 mail_prefetch_count = 20
117 # Default VSZ (virtual memory size) limit for service processes. This is mainly
118 # intended to catch and kill processes that leak memory before they eat up everything.
119 # Increased for fts_xapian.
120 default_vsz_limit = 1G
122 # DOC: https://doc.dovecot.org/configuration_manual/authentication/authentication_mechanisms/
123 # DOC: https://ldapwiki.com/wiki/DIGEST-MD5
124 # The misunderstanding is the notion "password sent over the network in plain-text" is not secure,
125 # when in fact, storing the password in the directory server using a Salted SHA-2 hash
126 # and transmitting the clear text password over a secure connection
127 # is more secure than having the directory server store the password in clear text
128 # or in a reversible encryption scheme.
129 # Therefore, SASL with DIGEST-MD5 (or CRAM-MD5) should be avoided.
130 # Use doveadm pw -s SSHA
131 # or doveadm pw -s PBKDF2 -r 10000
132 # or slappasswd -o module-load=pw-pbkdf2 -h "{PBKDF2-SHA256}"
133 auth_mechanisms = plain login
134 auth_username_format = %Ln
137 # Because auth_bind=yes and auth_bind_userdn are used,
138 # this cannot prefetch any userdb_*.
139 args = ${dovecot/ldap/sourcephile.fr.conf}
145 # A different path than passdb's args enables non-blocking LDAP requests
146 args = ${pkgs.symlinkJoin {name="ldap"; paths=[dovecot/ldap];}}/sourcephile.fr.conf
151 user = ${dovecot2.user}
152 # auth_socket_path points to this userdb socket by default. It's typically
153 # used by dovecot-lda, doveadm, possibly imap process, etc.
154 # Users that have access to this socket are able to get a list
155 # of all usernames and get results of everyone's userdb lookups.
156 unix_listener auth-userdb {
157 user = ${dovecot2.user}
158 group = ${dovecot2.group}
161 unix_listener /var/lib/postfix/queue/private/auth {
162 user = ${postfix.user}
163 group = ${postfix.group}
167 service auth-worker {
168 user = ${dovecot2.user}
170 auth_cache_verify_password_with_worker = yes
171 # SEE: http://wiki2.dovecot.org/Quota/FS
172 # NOTE: postfix does not supply a client cert.
173 auth_ssl_require_client_cert = no
174 #auth_ssl_username_from_cert = yes
175 # NOTE: lowercase the username, help with LDAP?
176 auth_username_format = %Lu
177 # NOTE: sync with LDAP's data.
178 first_valid_uid = 1000
179 disable_plaintext_auth = yes
181 # No dirty syncs for maildir: locations which may be used directly by neomutt
182 maildir_very_dirty_syncs = no
194 # NOTE: always listed in the LIST command.
196 # NOTE: how to access the other users' mailboxes.
197 # NOTE: %var expands to the logged in user's variable, while
198 # %%var expands to the other users' variables.
199 # NOTE: INDEX and CONTROL are shared, INDEXPVT is not.
200 location = sdbox:${stateDir}/mail/%%d/%%n/${stateDir}/mail.d:UTF-8:CONTROL=${stateDir}/control/%%d/%%n/Shared:INDEX=${stateDir}/index/%%d/%%n/Shared:INDEXPVT=${stateDir}/index/%d/%n/Shared/%%n
201 prefix = Partages+%%n+
205 mail_plugins = $mail_plugins virtual
212 location = virtual:${dovecot-virtual}:UTF-8:INDEX=${stateDir}/index/%d/%n/virtual
215 mail_plugins = $mail_plugins acl
217 acl = vfile:/etc/dovecot/acl/global.d
219 # NOTE: to let users LIST mailboxes shared by other users,
220 # Dovecot needs a shared mailbox dictionary.
221 # FIXME: %d not working with userdb ldap
222 acl_shared_dict = file:${stateDir}/acl/%d/acl.db
225 mail_plugins = $mail_plugins fts fts_xapian
227 plugin = fts fts_xapian
230 fts_autoindex_exclude = \Junk
231 fts_autoindex_exclude2 = \Trash
233 # 2 and 20 are the NGram values for header fields, which means the
234 # keywords created for fields (To, Cc, ...) are between is 2 and 20 chars long.
235 # Full words are also added by default.
236 fts_xapian = partial=2 full=20 verbose=0
239 mail_plugins = $mail_plugins quota
241 quota = maildir:User quota
242 quota_rule = *:storage=256M
243 quota_rule2 = Trash:storage=+64M
244 quota_max_mail_size = 20M
245 #quota_exceeded_message = </path/to/quota_exceeded_message.txt
246 quota_warning = storage=95%% quota-warning 95 %u
247 quota_warning2 = storage=80%% quota-warning 80 %u
248 quota_warning3 = -storage=100%% quota-warning below %u
252 hostname = ${networking.domain}
253 mail_plugins = $mail_plugins sieve
254 postmaster_address = postmaster+dovecot+lda@${networking.domain}
255 syslog_facility = mail
257 lda_mailbox_autocreate = yes
258 lda_mailbox_autosubscribe = yes
261 mail_plugins = $mail_plugins sieve
262 postmaster_address = postmaster+dovecot+lmtp@${networking.domain}
265 process_min_avail = ${toString config.nix.maxJobs}
266 unix_listener /var/lib/postfix/queue/private/dovecot-lmtp {
267 user = ${postfix.user}
268 group = ${postfix.group}
273 # Let extension.sieve do the handling of the detail
274 #lmtp_save_to_detail_mailbox = yes
275 recipient_delimiter = ${postfix.recipientDelimiter}
279 # Most of the memory goes to mmap()ing files.
280 # You may need to increase this limit if you have huge mailboxes.
285 #inet_listener imap {
286 # address = 127.0.0.1
290 inet_listener imaps {
295 # Store METADATA information within user's HOME directory
296 mail_attribute_dict = file:%h/dovecot-attributes
297 # If you have Dovecot v2.2.8+ you may get a significant performance improvement with fetch-headers:
298 imapc_features = $imapc_features fetch-headers
300 #mail_max_userip_connections = 10
301 mail_plugins = $mail_plugins imap_acl imap_quota imap_sieve virtual
304 # DOC: https://wiki.dovecot.org/MailboxSettings
305 # Due to a bug in Dovecot v2.2.30+ if special-use flags are used,
306 # SPECIAL-USE needs to be added to post-login CAPABILITY response as RFC 6154 mandates.
307 imap_capability = +SPECIAL-USE
312 special_use = \Archive
316 special_use = \Drafts
318 mailbox "Brouillons" {
320 special_use = \Drafts
335 mailbox "Pourriels" {
347 mailbox "Sent Items" {
351 mailbox "Sent Messages" {
364 mailbox "Corbeille" {
372 comment = All messages from all mailboxes
377 comment = All messages from all mailboxes arrived in the past 48h
382 #sieve_default = file:${stateDir}/mail/%u/default.sieve
383 #sieve_default_name = default
384 sieve_plugins = sieve_imapsieve sieve_extprograms
385 sieve_global_extensions = +vnd.dovecot.pipe +vnd.dovecot.environment
386 #sieve_extensions = +editheader
387 sieve = file:~/sieve.d;active=~/sieve
388 sieve_pipe_bin_dir = ${sieve_pipe_bin_dir}/bin
389 sieve_max_script_size = 1M
390 sieve_quota_max_scripts = 0
391 sieve_quota_max_storage = 10M
392 #sieve_spamtest_max_value = 10
393 #sieve_spamtest_status_header = X-Spam-Score
394 #sieve_spamtest_status_type = strlen
395 sieve_user_log = /var/log/dovecot/%d/sieve.%n.log
396 # Enables support for user Sieve scripts in IMAP
397 #imapsieve_url = sieve://mail.${networking.domain}:4190
399 # When a flag changes, spam or ham according to the \Junk or \NonJunk flags
400 imapsieve_mailbox1_name = *
401 imapsieve_mailbox1_causes = FLAG
402 imapsieve_mailbox1_before = file:${stateDir}/sieve/global/spam-or-ham.sieve
404 # From elsewhere to Junk folder
405 imapsieve_mailbox2_name = Pourriel
406 imapsieve_mailbox2_causes = COPY APPEND
407 imapsieve_mailbox2_before = file:${stateDir}/sieve/global/report-spam.sieve
409 # From Junk folder to elsewhere
410 imapsieve_mailbox3_name = *
411 imapsieve_mailbox3_from = Pourriel
412 imapsieve_mailbox3_causes = COPY
413 imapsieve_mailbox3_before = file:${stateDir}/sieve/global/report-ham.sieve
416 # Maximum number of ManageSieve connections allowed for a user from each IP address.
417 # NOTE: The username is compared case-sensitively.
418 mail_max_userip_connections = 10
420 # To fool ManageSieve clients that are focused on CMU's timesieved you can specify
421 # the IMPLEMENTATION capability that the dovecot reports to clients.
422 # For example: 'Cyrus timsieved v2.2.13'
423 managesieve_implementation_string = Dovecot Pigeonhole
425 # The maximum number of compile errors that are returned to the client upon script
426 # upload or script verification.
427 managesieve_max_compile_errors = 5
429 #mail_max_userip_connections = 10
430 #managesieve_implementation_string = Dovecot Pigeonhole
431 managesieve_max_compile_errors = 5
432 #managesieve_max_line_length = 65536
433 #managesieve_notify_capability = mailto
434 #managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
436 service managesieve-login {
437 inet_listener sieve {
442 # Number of connections to handle before starting a new process. Typically
443 # the only useful values are 0 (unlimited) or 1. 1 is more secure, but 0
444 # is faster. <doc/wiki/LoginProcess.txt>
447 # Number of processes to always keep waiting for more connections.
448 process_min_avail = 0
450 # If you set service_count=0, you probably need to grow this.
454 service quota-warning {
455 executable = script ${
456 pkgs.writeScript "quota-warning" ''
460 cat << EOF | ${pkgs.dovecot}/libexec/dovecot/dovecot-lda -d $USER -o
461 "plugin/quota=maildir:User quota:noenforcing"
462 From: postmaster@${networking.domain}
463 Subject: [WARNING] your mailbox is now $PERCENT% full.
465 Please remove some mails to make room for new ones.
469 # use some unprivileged user for executing the quota warnings
470 user = ${dovecot2.user}
471 unix_listener quota-warning {
476 mail_plugins = $mail_plugins virtual
477 #mail_max_userip_connections = 10
478 # Virtual namespace for the virtual INBOX.
479 # Use a global directory for dovecot-virtual files.
483 # location = virtual:''${dovecot-virtual-pop3}/pop3:INDEX=${stateDir}/index/%d/%n/virtual/pop3:LAYOUT=fs
486 pop3_client_workarounds =
487 pop3_fast_size_lookups = yes
488 pop3_lock_session = yes
489 pop3_no_flag_updates = yes
490 # Use GUIDs to avoid accidental POP3 UIDL changes instead of IMAP UIDs.
491 pop3_uidl_format = %g
497 inet_listener pop3s {
503 #${lib.concatMapStringsSep "\n"
505 # local_name mail.${dom} {
506 # #ssl_ca = <''${caPath}
507 # ssl_cert = <${x509.cert dom}
508 # ssl_key = <${x509.key dom}
514 #services.postfix.mapFiles."transport-dovecot" =
515 # toFile "transport-dovecot"
517 # (lib.mapAttrsToList
518 # (dom: {...}: "${transportSubDomain}.${dom} lmtp:unix:private/dovecot-lmtp")
519 # dovecot2.domains));