]> Git — Sourcephile - sourcephile-nix.git/blob - hosts/carotte.nix
carotte: try to upgrade
[sourcephile-nix.git] / hosts / carotte.nix
1 # NixOS configuration of carotte.sourcephile.fr
2 { inputs, hostName, lib, ... }:
3 {
4 #nixpkgs.crossSystem = lib.systems.examples.armv7l-hf-multiplatform;
5 nixpkgs.buildPlatform = {
6 system = "x86_64-linux";
7 config = "x86_64-unknown-linux-gnu";
8 };
9 nixpkgs.hostPlatform = {
10 system = "armv7l-linux";
11 config = "armv7l-unknown-linux-gnueabihf";
12 };
13 imports = [
14 {
15 install.substituteOnDestination = false;
16 }
17 (inputs.julm-nix + "/nixos/profiles/builder.nix")
18 (inputs.julm-nix + "/nixos/profiles/lang-fr.nix")
19 (inputs.julm-nix + "/nixos/profiles/networking/remote.nix")
20 #../nixos/profiles/systems/debug.nix
21 #carotte/fileSystems.nix
22
23 carotte/hardware.nix
24 #carotte/hostapd.nix
25 carotte/networking.nix
26 carotte/security.nix
27 carotte/system.nix
28 carotte/users.nix
29 #(inputs.secrets + "/hosts/${hostName}/users.nix")
30 #carotte/xserver.nix
31 ];
32 }