]> Git — Sourcephile - sourcephile-nix.git/blob - servers/mermet/security.nix
nix: deploy security.pass to mermet too
[sourcephile-nix.git] / servers / mermet / security.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config.security) pass;
4 rootKey = "root/key";
5 in
6 {
7 imports = [
8 #<nixpkgs/nixos/modules/profiles/hardened.nix>
9 ];
10 security.pass = {
11 store = ../../../sec/pass/servers/mermet;
12 secrets."${rootKey}" = {
13 gpg = ../../../sec/gnupg/servers/mermet/root/key.gpg;
14 # Symmetrically decrypt and load the rootKey into root's gnupg secret keyring.
15 postStart = ''
16 ${pkgs.gnupg}/bin/gpg --batch --pinentry-mode loopback \
17 --passphrase-file /${rootKey}.pass \
18 --import '${pass.secrets."${rootKey}".path}'
19 shred -u '${pass.secrets."${rootKey}".path}'
20 '';
21 };
22 };
23 install.ssh-nixos = {
24 PATH = with pkgs; [gnupg openssh];
25 # Decrypt the rootKey passphrase and send it to the target host.
26 script = lib.mkBefore ''
27 gpg --decrypt '${pass.store}/${rootKey}.pass.gpg' |
28 ssh '${config.install.ssh-nixos.target}' install -D -m 400 -o root -g root /dev/stdin /${rootKey}.pass
29 '';
30 };
31 systemd.services = lib.mapAttrs' (target: secret:
32 # Start the rootKey service before the other services decrypting secrets.
33 lib.nameValuePair (lib.removeSuffix ".service" secret.service)
34 (lib.optionalAttrs (target != "${rootKey}") {
35 after = [ pass.secrets."${rootKey}".service ];
36 wants = [ pass.secrets."${rootKey}".service ];
37 })
38 ) pass.secrets;
39 }