1 { pkgs, lib, config, ... }:
3 inherit (config) networking;
4 inherit (config.services) nginx;
8 ../../nixos/profiles/services/nginx.nix
9 nginx/sourcephile.fr.nix
11 users.groups."acme".members = [nginx.user];
12 users.groups."transmission".members = [nginx.user];
13 networking.nftables.ruleset = ''
14 add rule inet filter net2fw tcp dport 80 counter accept comment "HTTP"
15 add rule inet filter net2fw tcp dport 443 counter accept comment "HTTPS"
17 services.upnpc.redirections = [
18 { port = 80; protocol = "TCP"; }
19 { port = 443; protocol = "TCP"; }
23 package = pkgs.nginx.override {
24 modules = with pkgs.nginxModules; [
29 addresses = [ "127.0.0.1:53" ];
35 # Connection closed without response
39 useACMEHost = networking.domain;