1 { pkgs, lib, config, ... }:
3 inherit (config) networking;
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
11 # Avoid the use of systemd-run --user --scope tmux
12 # and let mosh work smoothly.
13 services.logind.killUserProcesses = false;
15 nix.gc.dates = "weekly";
16 nix.gc.options = "--delete-older-than 7d";
18 documentation.nixos = {
19 enable = false; # NOTE: useless on a server, and CPU intensive.
22 environment.systemPackages = with pkgs; [
38 #iptables-nftables-compat