1 # NixOS configuration of losurdo.sourcephile.fr
2 # Domenico Losurdo (1941-2018), historian for the working class
3 # https://www.monde-diplomatique.fr/2018/10/FONDU/59128
4 { inputs, nixpkgsPath, ... }:
6 system = "x86_64-linux";
7 # Define pkgs explicitely to be able to set allowUnfree
8 pkgs = import nixpkgsPath {
10 config.allowUnfree = true; # For hplip
12 import ../nixpkgs/overlays.nix ++
13 import (inputs.julm-nix + "/nixpkgs/overlays.nix");
17 config._module.args = {
22 (inputs.julm-nix + "/nixos/profiles/builder.nix")
23 ../nixos/profiles/systems/debug.nix
26 #losurdo/discourse.nix
28 losurdo/fileSystems.nix
32 losurdo/networking.nix
35 losurdo/postgresql.nix
36 losurdo/prometheus.nix
39 #losurdo/sourcehut.nix
43 losurdo/transmission.nix
46 (inputs.secrets + "/hosts/losurdo/users.nix")