1 { pkgs, lib, config, ... }:
3 inherit (builtins) elem attrValues;
4 inherit (config.users) users groups;
9 acme/sourcephile.fr.nix
14 environment.systemPackages = [
19 home = "/var/lib/acme";
20 group = groups."acme".name;
21 # Set a static UID to install the credentialFile
22 # with acme:root perms before the system switch
27 { assertion = ! elem users.acme.uid (attrValues config.ids.uids);
29 Unix user ID ${toString users.acme.uid} is already taken in config.ids.uids: change for a free UID.