1 { pkgs, lib, config, inputs, hostName, ... }:
4 (inputs.julm-nix + "/nixos/profiles/zfs.nix")
8 device = "${hostName}/root";
9 fsType = "zfs"; # TODO: options = [ "zfsutil" ];
12 # This will automatically load the zfs password prompt on login
13 # and kill the other prompt so boot can continue
14 # The pkill zfs kills the zfs load-key from the console
15 # allowing the boot to continue.
16 boot.initrd.network.postCommands = ''
17 echo >>/root/.profile "zfs load-key ${hostName} && pkill zfs"
19 boot.zfs.requestEncryptionCredentials = [ hostName ];
21 fileSystems."/nix" = {
22 device = "${hostName}/nix";
26 fileSystems."/var" = {
27 device = "${hostName}/var";
31 fileSystems."/var/cache" = {
32 device = "${hostName}/var/cache";
36 fileSystems."/var/log" = {
37 device = "${hostName}/var/log";
41 fileSystems."/var/tmp" = {
42 device = "${hostName}/var/tmp";
46 fileSystems."/mnt/key" = {
47 device = "/dev/disk/by-label/key";
49 options = [ "auto" "nofail" "uid=1000" "gid=users" "umask=111" "dmask=007" "utf8=yes" ];
52 # Allow members of the "adbusers" group to mount Android devices via MTP
53 services.udev.packages = [ pkgs.android-udev-rules ];
54 environment.systemPackages = [