]> Git — Sourcephile - sourcephile-nix.git/blob - machines/losurdo/system.nix
f3: enable on losurdo
[sourcephile-nix.git] / machines / losurdo / system.nix
1 { pkgs, lib, config, ... }:
2 let
3 inherit (config) networking;
4 in
5 {
6 # This value determines the NixOS release with which your system is to be
7 # compatible, in order to avoid breaking some software such as database servers.
8 # You should change this only after NixOS release notes say you should.
9 system.stateVersion = "19.09"; # Did you read the comment?
10
11 # Avoid the use of systemd-run --user --scope tmux
12 # and let mosh work smoothly.
13 services.logind.killUserProcesses = false;
14
15 nix.gc.dates = "weekly";
16 nix.gc.options = "--delete-older-than 7d";
17
18 services.unbound.enable = true;
19 documentation.nixos = {
20 enable = false; # NOTE: useless on a server, and CPU intensive.
21 };
22
23 environment.systemPackages = with pkgs; [
24 cryptsetup
25 direnv
26 f3
27 file
28 fio
29 gdb
30 git
31 gptfdisk
32 #hey
33 home-manager
34 lm_sensors
35 rsync
36 smartctl-tbw
37 socat
38 sanoid
39 #iptables-nftables-compat
40 gnupg
41 miniupnpc
42 audit
43 python
44 ];
45 }