]> Git — Sourcephile - sourcephile-nix.git/blob - nixos/modules/services/mail/postfix.nix
mermet: add postfix
[sourcephile-nix.git] / nixos / modules / services / mail / postfix.nix
1 { pkgs, lib, config, ... }:
2 let inherit (lib) types;
3 inherit (config) networking;
4 inherit (config.services) postfix;
5 in
6 {
7 options.services.postfix.aliases = lib.mkOption {
8 type = with types; attrsOf (listOf str);
9 default = {};
10 example = { "root@${networking.domain}" = [
11 "user1@${networking.domain}"
12 "user2@${networking.domain}"
13 ];
14 "@example.coop" = ["user1@${networking.domain}"];
15 };
16 };
17 }