1 # This is the root configuration of the target machine.
2 # Usable by nixos-install and used by nixops.
3 # It is NOT copied nor usable on the target machine,
4 # only the resulting closure is copied to the target machine.
5 { pkgs, lib, config, options
6 # NixOps extra module inputs
7 , nodes, name, uuid, resources
10 inherit (builtins) readFile;
11 inherit (builtins.extraBuiltins) pass pass-chomp;
14 # This value determines the NixOS release with which your system is to be
15 # compatible, in order to avoid breaking some software such as database servers.
16 # You should change this only after NixOS release notes say you should.
17 system.stateVersion = "19.09"; # Did you read the comment?
19 nixpkgs.overlays = import ../overlays.nix;
22 [ ../nixos/defaults.nix
39 domainBase = "sourcephile";
40 domain = "${domainBase}.fr";
47 initialPassword = password;
48 password = pass-chomp "servers/mermet/login/root";
49 openssh.authorizedKeys.keys = [
50 (readFile ../../sec/ssh/julm.pub)
51 (readFile ../../sec/ssh/julm-mob.pub)
60 systemPackages = with pkgs; [